New Templates Feature

Was super excited when I saw the template feature, but I cannot get it to work as in the official .gif

The name of the template (i.e. Daily Routine) does not get copied, but just the indented blocks.

Any idea what I’m doing wrong here?

Bonjour @niklas.

Because in the image you have your “Outline of: roam/templates” closed, I can’t tell…but you need that [[Daily Routine]] block ON the [[roam/templates]] Page. You can’t just reference it in the Block.

This is how I do it too so I know it works. :smiley:

Let me know if it still doesn’t work.

I am afraid that I can’t make head nor tail of it either. I’ve been trying to replicate the example in the GIF without success. The gif in the email seems to flash up some instructions but I can’t see any way of reading them. I have tried putting the template in the roam/templates page but it makes no difference.

This functionality was changed on Dec 30. See the change notes in the help database for version 0.7.8.

  • [[December 30th, 2020]]
    • [[Bug Fixes]]
      • Update to [[roam/templates]]
        • Only children of parent template block will be pasted where the trigger is called now
        • Allows for more flexibility and flat templates
        • Decouples the trigger name with the template
1 Like

I am seeing this work if I log into Roam from a PC but it doesn’t work if I repeat exactly the same command on my Mac.

On the PC, typing in ;; creates a popup showing templates that I’ve created
On the Mac, typing ;; does nothing

I can report that it is now working in both Safari and Chrome on my Mac so problem resolved somehow.

Anyone else having this same issue? I simply can’t get the popup menu to appear on my Mac.

I’m encountering the same issue as well on my MBA Big Sur 11.0.1, on both Firefox 85.0 and Safari, as well as iOS 14.2 Firefox.

I created the [[roam/templates]] Page, and created:

sc #roam/templates
     • [[sc]]
            • meta: [[session code]]

When I type ;;, I see the dropdown showing the sc template as an option but when I select it, nothing happens i.e. the template is not pasted in the block.